Intermittent Login Errors
Incident Report for mailgun
Resolved
This incident has been resolved.
Posted May 03, 2023 - 15:17 PDT
Identified
We have identified the cause of intermittent errors when logging into or navigating the Control Panel and are working on a fix.
Posted May 03, 2023 - 14:20 PDT
Investigating
We are currently investigating intermittent errors when logging into or navigating the Control Panel.
Posted May 03, 2023 - 13:51 PDT
This incident affected: Customer Tools (Control Panel).