Number of customer domains are suspended incorrectly
Incident Report for mailgun
Resolved
This incident has been resolved.
Posted Oct 15, 2020 - 13:56 PDT
Monitoring
The impacted domains have been re-enabled and we're monitoring the situation.
Posted Oct 15, 2020 - 11:36 PDT
Identified
We're experiencing an issue with a number of customer domains were incorrectly disabled. We are working to correct the rule that caused the domain to be disabled and re-enabling the domains.
Posted Oct 15, 2020 - 10:32 PDT
This incident affected: Email Services (Outbound Delivery).