Latency issues in EU
Incident Report for mailgun
Resolved
This incident has been resolved.
Posted Jul 31, 2021 - 19:20 PDT
Update
We are continuing to investigate this issue.
Posted Jul 31, 2021 - 18:20 PDT
Investigating
We are currently investigating this issue for the EU region.
Posted Jul 31, 2021 - 18:15 PDT
This incident affected: Email Services (Outbound Delivery, Events & Logs).