Inbound Message Delays
Incident Report for mailgun
Resolved
This incident has been resolved.
Posted Nov 26, 2019 - 21:56 PST
Monitoring
Route processing times have returned to expected levels, we will continue to monitor the situation.
Posted Nov 26, 2019 - 17:37 PST
Investigating
We are investigating issues affecting processing times with inbound Routed messages.
Posted Nov 26, 2019 - 14:09 PST
This incident affected: Email Services (Inbound email processing).