Latency issues in EU
Incident Report for mailgun
Resolved
This incident for the EU region has been resolved.
Posted Aug 03, 2021 - 02:35 PDT
Monitoring
A fix has been deployed for the latency issues in the EU, and we are monitoring the situation.
Posted Aug 03, 2021 - 02:22 PDT
This incident affected: Email Services (Outbound Delivery).