Minor message delays in US region
Incident Report for mailgun
Resolved
This incident has been resolved.
Posted Dec 02, 2022 - 09:25 PST
Monitoring
Bulk emails through our US regions are no longer experiencing delays.
Posted Dec 02, 2022 - 08:40 PST
Update
The delays would have only been seen for bulk message sending. Individual or "transactional" messages did not experience delays.
Posted Dec 02, 2022 - 08:21 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 02, 2022 - 07:54 PST
Investigating
We are currently experiencing minor email delivery delays in our US region.
Posted Dec 02, 2022 - 07:46 PST
This incident affected: Email Services (Outbound Delivery).